Ressuscitando o APT e atualizando o Navegador do LE5 + Bonus!


#1

Para as pessoas ainda presas ao LE5, este tutorial vai te quebrar um galhão! Assumo que você tenha algum conhecimento sobre linha de comandos. Você deve realizar esse tutorial logado como Admin!

Muito bem, o LE5 é baseado no “saudoso” Ubuntu 12.04 - Precise Pangolin. Como muitos já devem saber o 12.04 já chegou ao final de sua vida em 28 de Abril de 2017! Sendo assim, seus repositórios do apt foram mudados para old-releases.ubuntu.com a partir desta data, com isso você deve alterar os repositórios originais aonde se lê “br.archive” por “old-releases” e descomente a linha do repositório Ubuntu Partner que está desabilitado por padrão no LE5, para quem não sabe ainda descomentar a linha é remover o símbolo “#” do início da linha! Use o editor de texto de sua escolha, eu aqui vou mostrar pelo nano. No terminal:

sudo nano /etc/apt/sources.list

Altere sua sources.list para ficar assim:

#deb cdrom:[LE 5.0 _le5/escola_ - Release i386 (20140616)]/ precise main restricted
 
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://old-releases.archive.ubuntu.com/ubuntu/ precise main restricted
deb-src http://old-releases.archive.ubuntu.com/ubuntu/ precise main restricted
 
 ## Major bug fix updates produced after the final release of the
 ## distribution.
 deb http://old-releases.archive.ubuntu.com/ubuntu/ precise-updates main restricted
 deb-src http://old-releases.archive.ubuntu.com/ubuntu/ precise-updates main restricted
 
 ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
 ## team. Also, please note that software in universe WILL NOT receive any
 ## review or updates from the Ubuntu security team.
 deb http://old-releases.archive.ubuntu.com/ubuntu/ precise universe
 deb-src http://old-releases.archive.ubuntu.com/ubuntu/ precise universe
 deb http://old-releases.archive.ubuntu.com/ubuntu/ precise-updates universe
 deb-src http://old-releases.archive.ubuntu.com/ubuntu/ precise-updates universe
 
 ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
 ## team, and may not be under a free licence. Please satisfy yourself as to 
 ## your rights to use the software. Also, please note that software in 
 ## multiverse WILL NOT receive any review or updates from the Ubuntu
 ## security team.
 deb http://old-releases.archive.ubuntu.com/ubuntu/ precise multiverse
 deb-src http://old-releases.archive.ubuntu.com/ubuntu/ precise multiverse
 deb http://old-releases.archive.ubuntu.com/ubuntu/ precise-updates multiverse
 deb-src http://old-releases.archive.ubuntu.com/ubuntu/ precise-updates multiverse
 
 ## N.B. software from this repository may not have been tested as
 ## extensively as that contained in the main release, although it includes
 ## newer versions of some applications which may provide useful features.
 ## Also, please note that software in backports WILL NOT receive any review
 ## or updates from the Ubuntu security team.
 deb http://old-releases.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
 deb-src http://old-releases.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
 
 deb http://security.ubuntu.com/ubuntu precise-security main restricted
 deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
 deb http://security.ubuntu.com/ubuntu precise-security universe
 deb-src http://security.ubuntu.com/ubuntu precise-security universe
 deb http://security.ubuntu.com/ubuntu precise-security multiverse
 deb-src http://security.ubuntu.com/ubuntu precise-security multiverse
 
 ## Uncomment the following two lines to add software from Canonical's
 ## 'partner' repository.
 ## This software is not part of Ubuntu, but is offered by Canonical and the
 ## respective vendors as a service to Ubuntu users.
 deb http://archive.canonical.com/ubuntu precise partner
 deb-src http://archive.canonical.com/ubuntu precise partner
 
 ## This software is not part of Ubuntu, but is offered by third-party
 ## developers who want to ship their latest software.
 deb http://extras.ubuntu.com/ubuntu precise main
 deb-src http://extras.ubuntu.com/ubuntu precise main

Depois será necessário remover os repositórios quantal-repos.list e java-repos.list. Eles não funcionam mais e só vão ficar dando erros.

No terminal:

sudo rm /etc/apt/sources.list.d/quantal-repos.list

e

sudo rm /etc/apt/sources.list.d/java-repos.list

Depois das mudanças, atualize a sua lista e o sistema:

sudo apt-get update
sudo apt-get dist-upgrade

Essa atualização será extensa, serão cerca de 460 pacotes atualizados e 488MB de dados serão baixados!

Com isso o Firefox que antes era a versão 30 vai para a versão 52.

Reinicie o sistema depois da atualização terminar.

Você também tem a opção de instalar o Chromium, a versão livre do Google Chrome, no terminal:

sudo apt-get install chromium-browser

O Chromium é mais leve que o Firefox.

Bonus!

Vamos instalar mais alguns pacotes que talvez você vai precisar:

sudo apt-get install intel-microcode adobe-flashplugin ubuntu-restricted-addons ubuntu-restricted-extras gstreamer0.10-ffmpeg gstreamer0.10-fluendo-mp3 ffmpeg flac audacious dconf-tools gnome-tweak-tool

Agora procure por dconf-editor na busca de aplicativos do Gnome.

Dentro do aplicativo org > gnome > desktop > interface

Desabilite as animações do Gnome! Seu velho PC agradece de montão!

Também procure pelo tweak-tool, vai aparecer como configurações, aí você poderá alterar
vários detalhes da configuração do Gnome.

Depois reinicie o sistema.

Pronto, agora seus navegadores estão abrindo o Youtube, Friv e um monte de páginas dinâmicas e o seu sistema está um pouquinho mais esperto!

Espero ter ajudado mais que atrapalhado.

Qualquer erro é só falar!


Como atualizar o firefox no linux educacional 5.0, nos computadores do pregão 23/2012
#2

Olá, bom dia! Sou professor de laboratório de informática, tenho pouco conhecimento em Linux e estou com algumas dúvidas. Eu fiz os procedimentos assim:

Apaguei no Nano o conteúdo do meu sources.list e substitui pelo conteúdo que vc colocou aqui. Aí deu esse erro: “Não é possível ler See http://help.ubuntu…”.

Apaguei todos os textos e deixei no sources.list só os “deb alguma coisa”. Consegui prosseguir.

Só que aí quando chegou no sudo apt-get dist-upgrade deu o erro que aparece na imagem em anexo.

Por favor, como eu poderia resolver esse erro? Obrigado!

Captura%20de%20tela%20de%202018-06-13%2008%3A01%3A04


#3

Veja se a sua sources.llist está igual a essa que eu editei acima!

Execute o comando

sudo apt-get -f install

e depois

sudo apt-get update
sudo apt-get dist-upgrade


#4

Bom dia @galactus! Obrigado por responder rápido!

Deixei minha lista igual a sua (parte de cima da tela):

Captura%20de%20tela%20de%202018-06-14%2008%3A12%3A21%20TELA%201

Parte de baixo da mesma tela:

Captura%20de%20tela%20de%202018-06-14%2008%3A12%3A26%20TELA%202

Depois fiz o sudo apt-get -f install e deu isso:

Captura%20de%20tela%20de%202018-06-14%2008%3A09%3A22

Aí parei nesse erro.


#5

Já tive esse problema com os pacotes do OpenSSH quando experimentei o LE5 há alguns anos.

Experimente desinstalar e reinstalar os pacotes relevantes:

sudo apt-get purge openssh-client openssh-server ssh
sudo apt-get install ssh

#6

Problema resolvido!!!
[Em breve @galactus vai fazer um resumo da solução!]

Muitíssimo obrigado @galactus!!! :smiley:


#7

Obrigado pela ajuda! Na próxima vez que eu tiver um problema parecido vou ver se é possível resolver por aí!

Obrigado!


#8

Olá pessoal. Então, o Jaerton entrou no grupo do WhatsApp do Linux Educacional e por lá eu ajudei ele a resolver o problema.

O que aconteceu em especial nessa máquina dele é que houve um corrompimento do apt dessa máquina do laboratório do Jaerton. Em outras máquinas do laboratório dele esse problema não ocorreu. O tutorial funcionou sem problemas.

Mas vamos lá ao que fizemos para resolver.

sudo mv /var/log/apt /var/log/apt.bak
sudo rm /var/lib/apt/lists/* -vf
sudo apt-get clean
sudo apt-get update
sudo apt-get remove --purge openssh-server
sudo apt-get remove --purge openssh-client
sudo dpkg -r openssh-server
sudo  dpkg -r openssh-client
sudo apt-get -f install
sudo  apt-get autoclean
sudo dpkg --configure -a
sudo  apt-get update
sudo  apt-get dist-upgrade

E UFA! O sistema foi atualizado. O problema todo estava com o pacote openssh-server e o corrompimento do apt. Sem Apagar o Log e as informações do sources.list ele não removia o pacote. E sem a remoção do pacote problemático, nada era instalado ou desinstalado, mesmo com o apt-get remove ou apt-get -f install.

Então era isso pessoal! Que bom que funcionou tudo direitinho depois!