Não consigo instalar Epoptes no LE 5.0


#1

Err http://br.archive.ubuntu.com/ubuntu/ quantal/universe x11vnc-data all 0.9.13-1ubuntu1
404 Not Found
Alguém pode me ajudar?
Obrigado.


#2

Olá Guilherme. Quando você tenta atualizar sua sources.list, dá algum erro?

É que eu aqui tive vários erros com a lista de resipositórios padrão do LE 5.0. Só resolveu pra mim quando saí da lista do Brasil para a principal!

Como o Synaptic está bloqueado para alterações da lista de respositórios, vocẽ pode alterar essa lista manualmente pelo terminal.

Você sabe alterar essas coisas?

Abra o terminal e execute:

sudo su ( seguido da sua senha de Adminstrador + ENTER)

gedit /etc/apt/sources.list

Verifique se a sua lista está como a minha, você deve remover os “br” das linhas com http://br.archive.ubuntu.com/ubuntu/…

Minha lista é a seguinte:

#deb cdrom:[LE 5.0 le5/home - Release i386 (20140618)]/ precise main restricted

See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to

newer versions of the distribution.

deb http://archive.ubuntu.com/ubuntu/ precise main restricted
deb-src http://archive.ubuntu.com/ubuntu/ precise main restricted

Major bug fix updates produced after the final release of the

distribution.

deb http://archive.ubuntu.com/ubuntu/ precise-updates main restricted
deb-src http://archive.ubuntu.com/ubuntu/ precise-updates main restricted

N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu

team. Also, please note that software in universe WILL NOT receive any

review or updates from the Ubuntu security team.

deb http://archive.ubuntu.com/ubuntu/ precise universe
deb-src http://archive.ubuntu.com/ubuntu/ precise universe
deb http://archive.ubuntu.com/ubuntu/ precise-updates universe
deb-src http://archive.ubuntu.com/ubuntu/ precise-updates universe

N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu

team, and may not be under a free licence. Please satisfy yourself as to

your rights to use the software. Also, please note that software in

multiverse WILL NOT receive any review or updates from the Ubuntu

security team.

deb http://archive.ubuntu.com/ubuntu/ precise multiverse
deb-src http://archive.ubuntu.com/ubuntu/ precise multiverse
deb http://archive.ubuntu.com/ubuntu/ precise-updates multiverse
deb-src http://archive.ubuntu.com/ubuntu/ precise-updates multiverse

N.B. software from this repository may not have been tested as

extensively as that contained in the main release, although it includes

newer versions of some applications which may provide useful features.

Also, please note that software in backports WILL NOT receive any review

or updates from the Ubuntu security team.

deb http://archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu precise-security main restricted
deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
deb http://security.ubuntu.com/ubuntu precise-security universe
deb-src http://security.ubuntu.com/ubuntu precise-security universe
deb http://security.ubuntu.com/ubuntu precise-security multiverse
deb-src http://security.ubuntu.com/ubuntu precise-security multiverse

Uncomment the following two lines to add software from Canonical’s

‘partner’ repository.

This software is not part of Ubuntu, but is offered by Canonical and the

respective vendors as a service to Ubuntu users.

deb http://archive.canonical.com/ubuntu precise partner

deb-src http://archive.canonical.com/ubuntu precise partner

This software is not part of Ubuntu, but is offered by third-party

developers who want to ship their latest software.

deb http://extras.ubuntu.com/ubuntu precise main
deb-src http://extras.ubuntu.com/ubuntu precise main

Eu também desabilitei o repositório do java e do quantal que ficam no sources.list.d . Se não souber do que estou falando depois pergunte!

Após as alterações na lista principal, salve as alterações no Gedit e feche o arquivo.

No terminal, ainda como root, execute:

apt-get update

apt-get dist-upgrade

apt-get install epoptes

Veja se tudo correu bem. Se deu algo errado copie e cole aqui as saídas dos comandos no terminal.

No aguardo!


Atualização do Firefox e instalação do Chrome
#3

Esses repositórios estão desligados.

Em funcionamento só do Linux Educacional 6:

See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to

newer versions of the distribution.

deb http://br.archive.ubuntu.com/ubuntu/ xenial main restricted

deb-src http://br.archive.ubuntu.com/ubuntu/ xenial main restricted

Major bug fix updates produced after the final release of the

distribution.

deb http://br.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

deb-src http://br.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu

team. Also, please note that software in universe WILL NOT receive any

review or updates from the Ubuntu security team.

deb http://br.archive.ubuntu.com/ubuntu/ xenial universe

deb-src http://br.archive.ubuntu.com/ubuntu/ xenial universe

deb http://br.archive.ubuntu.com/ubuntu/ xenial-updates universe

deb-src http://br.archive.ubuntu.com/ubuntu/ xenial-updates universe

N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu

team, and may not be under a free licence. Please satisfy yourself as to

your rights to use the software. Also, please note that software in

multiverse WILL NOT receive any review or updates from the Ubuntu

security team.

deb http://br.archive.ubuntu.com/ubuntu/ xenial multiverse

deb-src http://br.archive.ubuntu.com/ubuntu/ xenial multiverse

deb http://br.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

deb-src http://br.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

Uncomment the following two lines to add software from the ‘backports’

repository.

N.B. software from this repository may not have been tested as

extensively as that contained in the main release, although it includes

newer versions of some applications which may provide useful features.

Also, please note that software in backports WILL NOT receive any review

or updates from the Ubuntu security team.

deb http://br.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

deb-src http://br.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

Uncomment the following two lines to add software from Canonical’s

‘partner’ repository.

This software is not part of Ubuntu, but is offered by Canonical and the

respective vendors as a service to Ubuntu users.

deb http://archive.canonical.com/ubuntu xenial partner
deb-src http://archive.canonical.com/ubuntu xenial partner

deb http://security.ubuntu.com/ubuntu xenial-security main restricted

deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted

deb http://security.ubuntu.com/ubuntu xenial-security universe

deb-src http://security.ubuntu.com/ubuntu xenial-security universe

deb http://security.ubuntu.com/ubuntu xenial-security multiverse

deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse

deb http://br.archive.ubuntu.com/ubuntu/ xenial-proposed restricted main multiverse universe


#4

Sei que 12.04 já chegou no fim de sua vida, mas os repositórios continuam funcionando, se ele usar esta lista acima!

Dá pra atualizar o sistema de uma instalação padrão do LE5 e instalar um monte de coisas ainda!

Tô usando o LE5 e essa lista. Hoje mesmo instalei o Epoptes que ele não conseguiu!


#5

O Linux Educacional 6 já virá com o Epoptes instalado e a configuração será automática. Quando um professor ou administrador abre o Epoptes em qualquer computador, todos os usuários são conectados automaticamente.


#6

Bom dia!
Primeiro gostaria de agradecer o suporte. Consegui instalar o epoptes, depois que retirei o br do sources.list.
Mas ainda dá erro no quantal. Como faço para desabilitar?
Obrigado.
Guilherme


#7

Olá @guilherme. Então, para acabar com os erros do restante da lista eu removi da minha lista no LE5 o Quantal e o Java.

Você abre o terminal e entra como root: sudo su+ ENTER e depois sua senha

Aí entre na pasta sources.list.d:

cd /etc/apt/sources.list.d

Lista o que está aí dentro:

ls

Você deve encontrar três arquivos, o do Quantal, o do Java e do LE, todos terminando com a extensão .list. Aí você pode apagar esses arquivos ou renomear os mesmo. Eu, como disse antes, apaguei esses arquivos da minha lista, não ia me servir pra nada. Se quiser renomear eles fica a seu critério.

Para apagar, estando dentro da pasta como mostrado acima, digite:

rm quantal-repos.list
rm java-repos.list

Se quiser renomear os arquivos ao invés de apagar vou te deixar com essa “sarna para se coçar”! :slight_smile:

Depois de apagar os aquivos atualize a lista:

apt-get update

Deve ficar sem erros agora!

Boa sorte!


#8

Obrigado mais vez. Deu certo, remove o quantal e o java, mas ainda ficou le-repos.list, preciso remover?
Obrigado novamente.
Guilherme


#9

De nada! Não remova o le-repos.list!


#10

Ok. Mas te fazer uma pergunta. O epoptes está instalado e funcionando, mas quando passa algum tempo algumas estações desaparecem da tela, aí tenho que reiniciar a estação para voltar a vê-la. Porque isso acontece?


#11

Se a versão do Epoptes (server e client) que você tem instalada aí for anterior à 0.5.10, então você está suscetível a este tipo de problema, sim (principalmente se a sua rede local for wi-fi).

O que ocorre é que, diferentemente do iTALC, no Epoptes as conexões são reversas, isto é, são os alunos que se conectam ao professor. Se, por algum motivo, os alunos se desconectam do servidor (por exemplo, se o servidor for reiniciado ou se a rede wi-fi apresentar instabilidade), o epoptes-client não refaz a conexão depois, sendo necessário reiniciá-lo também (a reconexão automática do epoptes-client só foi introduzida na versão 0.5.10).

E por que era assim? Porque o Epoptes foi concebido para rodar originalmente em laboratórios baseados em LTSP, em que você tem um servidor parrudo e vários thin clients que dão boot pela rede, carregando o sistema a partir do servidor. Como neste caso, se há perda de conexão dos thin clients com o servidor, eles precisam ser reiniciados de qualquer forma, o pessoal do Epoptes não se preocupou muito com isto.


#12

Então não tem solução?


#13

Você pode tentar atualizar o Epoptes para a versão 0.5.10 a partir do PPA oficial do projeto:

https://launchpad.net/~epoptes/+archive/ubuntu/ppa?field.series_filter=trusty

Teoricamente, você poderia realizar o procedimento facilmente com os seguintes comandos:

sudo apt-add-repository ppa:epoptes
sudo apt-get update
sudo apt-get upgrade

No entanto, o comando apt-add-repository costuma falhar no Linux Educacional, pois este não se apresenta como “Ubuntu” para aquele. Se o comando falhar, você pode adicionar o repositório manualmente. Como root, crie um arquivo chamado /etc/apt/sources.list.d/ppa-epoptes.list com o seguinte conteúdo:

deb http://ppa.launchpad.net/epoptes/ppa/ubuntu trusty main
deb-src http://ppa.launchpad.net/epoptes/ppa/ubuntu trusty main

Depois de criar o arquivo, execute os comandos abaixo:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 0350B375
sudo apt-get update
sudo apt-get upgrade

#14

Realmente da erro com apt-add-reposirory. Tem como vc me ensinar criar esse arquivo?
Obrigado.


#15
  1. sudo nano /etc/apt/sources.list.d/ppa-epoptes.list
  2. Escreva o conteúdo acima
  3. Salve o arquivo com [Control]+[O]
  4. Saia com [Control]+[X]

#16

Fiz tudo e não deu certo. Passa alguns minutos e as telas vão desaparecendo do epoptes.
Mas mesmo assim muito obrigado.


#17

Bom dia! @ibssousa, depois que coloquei ip fixo no servidor, passou algum tempo e as telas não desapareceram. Gostaria de agradecer.
Mas também gostaria de saber como faço para instalar o google chrome no linux educacional 5.0, pois, preciso dar curso de gsuite e pelo chromium é muito ruim. Quando vou instalar o google chrome, diz que tem sistema de 64 bits. Tem alguma solução para poder instalar ?
Obrigado.
Guilherme


#18

@guilherme, no LE6 o epoptes é instalado por padrão e nenhuma configuração é necessária nem nos terminais. Basta o professor (usuário professor) abrir o epoptes em sua máquina que os computadores do alunos se conectam automaticamente. Fique à vontade para testar a nova solução e deixar seus comentários aqui no fórum. Obrigado.


#19

Olá @dpasqualin, bom dia!

Mas o LE6 roda em máquinas do pregão 83/2008? O LE6 tem alguma opção para deixa-lo mais leve?

Obrigado!


#20

Deixar o LE 6 mais leve?
Tá na ponta de um click: