Multiterminal ativação no UBUNTU 16.04 LTS


#27

Você não deve ter criado permissão para o seu usuário.
Crie um adicionando adduser professorX e dê permissão gpasswd -a professorX sudo
Tudo isso deve ser feito antes para poder usar o terminal tranquilamente.
Não se esqueça de criar seu usuário pois o sistema ainda é beta.
:slight_smile:


#28

Não há necessidade de criar um usuário específico para utilizar essa solução do multiterminal, o sistema já vem com o usuário admin e professor.


#29

@pperigob Os computadores de seu laboratório são de qual pregão ? Onde baixo o XUBUNTU 32 bits ou pode ser qualquer site ?


#30

Sim, estava me referindo que pode ser criado um usuário pessoal com o nome dele e ter permissões para usar o terminal. :slight_smile:


#31

O Site do Xubuntu é esse: https://xubuntu.org/


#32

Olá aqui em Goiânia, temos duas escolas com esse pregão e funcionou os 5 terminais, apenas inclui mais uma memória de 1gb, a máquina ficou com 2gb. Mas usei a solução de multiterminal da galera de Minas Gerais. Posso te passar a solução que tivemos. É importante frisar que utilizamos o LE 5.0 original, um abraço.

https://docs.google.com/document/d/1yYR0hq0xby5IgDCl1dSnVUBX8ac2UCQTd02ZgUh8APg/edit


#33

Ola tudo bem.
Somos representante e Assistência técnica dos novos minipoint ethernet o multiterminal da ThinNetworks
Fico a disposição para alinharmos suporte que venha precisar. sacsolution@hotmail.com

Solution Tech informática em Fortaleza-Ceará 85 30445172 ,
Agradeço desde já atenção …


#34

Novo projeto para multiterminais baseado no Ubuntu 16.04.3 LTS e posteriores!


#35

Olá, @Solutiontechinformat !

Pelo que conseguimos colegar de informações até o momento para configurar corretamente o multiterminal no Ubuntu 16.04 e posteriores utilizando hardware da ThinNetworks, encontramos as seguintes limitações:

  • O driver de código aberto xf86-video-siliconmotion, incluído por padrão no Ubuntu 16.04 e em diversas outras distribuições Linux, precisa urgentemente de manutenção. Atualmente, ele só é compatível com o chip SM501, utilizado nas placas TN-502, inviabilizando a solução para os computadores do pregão 23/2012 (que são equipados com placas TN-750 baseadas no chip SM750, ainda sem suporte no referido driver).

  • Além disso, algumas placas de vídeo TN-502 têm apresentado um “bug da tela listrada” na saída de vídeo LVDS (aquela convertida em VGA usando um cabo flat).bug-tela-listrada
    A única solução paliativa que encontramos para contornar este bug e dar boot primeiro em um sistema “live” com o Userful Multiseat pré-habilitado e, em seguida, reiniciar (sem desligar o computador) de volta para o Ubuntu.

  • Os drivers atualmente “mantidos” pela ThinNetworks, que funcionam para ambas as placas TN-502 e TN-750, só funcionam com o servidor Xorg modificado pela Userful (software proprietário). Não conseguimos, até o momento, fazer estes drivers funcionarem com o Xorg original.

  • Pensando no futuro do suporte ao Linux para o hardware da ThinNetworks, é imprescindível que haja drivers de vídeo implementados no nível do kernel (conhecidos como drivers “DRM/KMS”, ou “Direct Rendering Manager/Kernel Mode Setting”) compatíveis com este hardware. Você mencionou o MiniPoint Ethernet; saberia me dizer se há drivers DRM/KMS compatíveis com ele?

  • No momento, eu não disponho de tempo livre nem capacidade técnica para trabalhar na criação e manutenção de tais drivers (e talvez o pessoal do C3SL também não o tenha), mas seria interessante se vocês conseguissem compatibilizar os drivers originalmente criados para a solução da Userful, para que funcionem no Xorg original.


#36

Eu fiz todo o procedimento o sistema não ativou os demais terminais no LE 6.0!


#37

Segue um checklist que eu costumo indicar para os meus colegas quando há algum problema com os multiterminais:

  1. A placa de vídeo TN-502 está funcionando corretamente? Execute lspci | grep SM501 e veja se aparece alguma informação referente à placa. Se não aparecer, então provavelmente a placa está com defeito ou mau contato. IMPORTANTE: nossa solução para o multiterminal não funciona nos computadores do pregão 23/2012!

  2. Os hubs USB estão funcionando corretamente? Execute loginctl list-seats e veja se são listados os terminais seat-sm501-0-lvds e/ou seat-sm501-0-vga. Se não aparecer, é provável que os hubs estejam ligados nas portas USB erradas, ou o pacote oi-lab-proinfo-multi-seat-utils não tenha sido instalado corretamente, ou o computador precise ser reiniciado para as novas regras do udev surtirem efeito.


#38

e3f4c47d-7f8a-4fd1-8666-255dd78c6115fdac02db-eb74-4824-bc3f-43d77184bae4
Ai, todos eles assim e não iniciam os terminais!


#39

OK. Tudo certo até aqui. Os próximos passos são os seguintes:

  1. Verifique se você tem o pacote xserver-xorg-core-hwe-16.04 instalado no seu sistema. Execute:
dpkg -l | grep xserver-xorg-core

e veja se aparece xserver-xorg-core ou xserver-xorg-core-hwe-16.04. IMPORTANTE: a nossa solução para o multiterminal funciona apenas com o pacote xserver-xorg-core-hwe-16.04.

Caso seja necessário instalar o xserver-xorg-core-hwe-16.04, utilize o comando abaixo:

sudo apt-get install --install-recommends xserver-xorg-hwe-16.04

OBS: Não me responsabilizo por uma eventual quebra do LE6, caso alguma coisa dê errado nesta atualização. Sugiro fazer este procedimento em uma máquina de testes primeiro!

  1. Verifique quais processos do Xorg estão em execução:
ps -FC Xorg | less

Se estivesse tudo OK, deveriam aparecer (n+1) instâncias do Xorg em execução (n é o número de terminais):

  • Um Xorg rodando no display :90, que é executado pelo serviço do systemd oi-lab-xorg-daemon@0.service. Ele serve de fundo para rodar outras instâncias do Xorg em cima dele, pra poder subir dois terminais numa mesma placa de vídeo.
  • Outros Xorgs rodando nos displays :0, :1 ou :2, que correspondem aos terminais.

Caso o Xorg no display :90 ou algum outro não estiver em execução, vasculhe os arquivos de log /var/log/Xorg.NUMERO.log em busca de mensagens de erro (elas são marcadas com EE).


#40

Será que dá para parar de falar em Xubuntu aqui??? Esse fórum é do LE 6.0 e não do Xubuntu…
Parabéns a vocês todos que se esforçam para ajudar a solucionar a questão do multiterminal no LE 6.0 !
Eu agradeço em nome dos educadores brasileiros e em nome de milhões de alunos urbanos e rurais que vão vão ficar muito felizes em utilizá-lo nas escolas públicas brasileiras!

Grato, :yum:
Parabéns pelo esforço e dedicação de vocês!


#41

Bom dia! É a demotracia, irmão!!


#42

Eu acho que não :grin: (pelo menos por enquanto). E diria mais: precisamos falar mais sobre o Lubuntu também.

Explico: quando nós começamos a pesquisar e desenvolver esta solução para os multiterminais, o desenvolvimento do LE 6.0 ainda não havia começado, então partimos diretamente da fonte, a família Ubuntu 16.04. Dentre os diversos sabores do Ubuntu que experimentamos em Mogi das Cruzes-SP, o Xubuntu foi o que melhor equilibrou a leveza e a riqueza de recursos e por isso vem sendo a nossa base de testes até o momento. No entanto, ao longo do desenvolvimento do LE 6.0, a interface escolhida, segundo os critérios estabelecidos pelo C3SL, foi a gnome-shell.

Não sei se alguém aí já testou a nossa solução diretamente no LE 6.0 (vou iniciar meus testes hoje), mas o meu palpite é de que a interface gnome-shell adotada nele deve ficar pesada para as fraquíssimas placas de vídeo TN-502. Além disso, o LE 6.0 (ao menos por enquanto) só está disponível para a arquitetura de 64 bits, tornando-o inviável para computadores do pregão 83/2008 com apenas 1 GB de RAM.

Não sei se está nos planos do C3SL continuar com o suporte ao pregão 83/2008, mas, em todo caso, à medida que os testes com os multiterminais avançarem, imagino que seja interessante discutir a possibilidade de se criar um “LE 6.0 Lite”, possivelmente baseado no Xubuntu ou Lubuntu, para atender a essa demanda (em nossos testes aqui em Mogi, apenas o Lubuntu de 32 bits, com o navegador Chromium e o zRAM ativado, conseguiu um desempenho satisfatório em 3 terminais com apenas 1GB de memória RAM).


#43

Agradeço a todos do Forum e principalmente ao prof Laércio Sousa que com seus roteiros tornaram possível a soluçäo multiterminal, mesmo em pregöes 23/2012 após a substituiçäo da placa TN 750 pela TN 502. Tudo bem explicado pelo Laércio de Mogi das cruzes.


#44

Laércio, estou com máquinas do pregäo 23/2012 funcionando perfeitamente com 4 Gb ram e substitui as TN 750 pelas TN 502 com sucesso (agradeço a vc pela dica). Aqui no Instituto Federal todos estäo satisfeitos com o Linux Educacional 6 multiterminal. Nos L/X/ubuntu os terminais a princípio travavam. Seu roteiro funcionou bem no LE 6, pregäo 23/2012 com placa de video TN 502.


#45

Amigo como vc ativou o multiterminal no xubunto?


#46

Sim, através das orientações encontradas nesse link:

http://gitlab.sme-mogidascruzes.sp.gov.br/pte/proinfo-ubuntu-config/wikis/Obtencao-dos-arquivos-de-configuracao-do-multiterminal