Erros encontrados no linux educacional 6


#23

Obrigado pelo feedback @galactus! O le-interface deveria ter feito isso automaticamente. Vamos verificar aqui o que ocorreu.


#24

De nada! Fico feliz em ajudar!


#25

Le-Lab voltou a “Crashar”!

Relatório do erro:

Pacote: le-lab 0.2.2

le-lab crashed with Index Error insetup_service_attributes: list index out of range

Versão do le-interface: 0.1.16
VErsão do le-epoptes: 0.0.11

Interessante que ele “Crasha” na instalação padrão. Na instalação com o backports ativo, PPA para driver de vídeo e kernel 4.10-hwe, além do Lightdm no lugar do GDM, ele não “Chrashou”!


#26

Olá, Bom dia!

Estou estudando a respeito do LE 6 para por a funcionar no laboratório da escola onde trabalho mas estou com um problema um tanto “chato”. Toda vez que esperimento o LE 6 na maquina de testes, seja por imagem ISO, Usb ou DvD. os seguintes erros aparecem:

Ao fim da instalação, depois da primeira reinicialização...

Erro 1

E quando o sistema está completamente reiniciado! Aparecê isso

Imagem do Google Drive

E durante o login caso eu não tenha posto para iniciar sessão automaticamente (OBS: isso foi quando testei para instalação no particular, )

Imagem Google Drive - 3

Resumindo o “Não está listado?”, está sempre presente em qualquer um dos casos.
Não importando o tipo de mida ou maquina que eu gere no meu ambiente de testes sempre impaco nisso.
Poderiam me dizer se eu que não estou conseguindo (mesmo seguindo o manual de instalação a risca) ou existe alguma rejeição do sistema a maquinas virtuais? tipo VM.


#27

Olá @Marcelo. Não sou desenvolvedor do LE, mas você poderia ajudar um pouco mais com o seu relato com: a configuração do seu Hardware e se esta sua instalação é numa máquina virtual, que máquina virtual é essa? VirtualBox ou VmWare? Há sim, qual o sistema operacional Hospedeiro?


#28

Eu observei o mesmo problema instalando o LE 6.0 (ISO datada de 2017-10-18) versão Escola em uma das máquinas do meu laboratório. O que está acontecendo é o seguinte:

  • O gerenciador de login GDM está sendo instalado/habilitado por padrão no lugar do LightDM.
  • Os usuários admin e professor não estão sendo criados corretamente durante a instalação.

Claramente, trata-se de um bug na ISO do LE 6.0, mas acredito que o pessoal do C3SL conseguirá resolvê-lo rapidamente.


#29

Entendi muito obrigado, por me esclarecer!
Existe alguma data prevista para a correção deste Bug?


#30

Ola!
estou usando a VirtualBox, meu sistema é o Linux Mint 18.2 64bits.

Placa de vido Geforce 8400 Gs 1 gb.

as maquinas virtuais que crio são primariamente de linux ubuntu 64 bits tambem, o ubuntu nas suas versão 14.4 e 16.4, foram minhas tentativas, mas tambem tentei nas opções de outros linux, todas elas em vão, sempre o mesmo erro. E agora que li na C3SL é um bug na iso.


#31

fiz uma instalação no virtual box e deu tudo certo, passei pra uma maquina do laboratório e apresento os mesmos problemas. baixei de novo a ISO e os usuário apareceram normalmente. Mas agora deu erro na senha do professor e Admin. so entra no convidado.


#32

Olá, após tantas modificações no LE6 desde o lançamento da ISO Beta, não poderiam fazer uma nova ISO, tipo Beta2 com tudo já embutido pra gente testar de uma instalação zerada?

Acredito que poderíamos descobrir novos Bugs principalmente de instalação!


#33

Você pode acompanhar o andamento deste bug aqui:


#34

Olá @Marcelo, em relação a primeira tela , este é um comportamento que ocorre apenas na VM por conta das otimizações feitas na hora de ligar a maquina, em uma instalação normal essa tela não aparece.
O outro erro destacado de não exibir os usuários ainda persiste? Acreditamos que o erro tenha sido corrigido na nova versão do le-conf(pacote responsável pela criação dos usuários na versão escola).


#35

Vocês já geraram uma nova ISO do LE6 com o pacote le-conf atualizado? Estou com a ISO do dia 18/10/2017 e o problema ainda persiste nela.


#36

Bom dia @lbssousa, a instalação esta sendo feita com internet ou sem? este pacote é baixado e instalado toda vez que uma instalação do sistema é concluída, caso ela esteja sendo feita sem internet o problema persiste por conta da versão do pacote mantida na ISO.


#37

Então @DanielFurlin, você diz que a gente usa a ISO antiga mesmo mas antes de instalar tem que atualizar o sistema?

Pra poder usar a nova versão do le-conf? É isso?

Como já questionei acima, não seria melhor criar outra ISO com todas as atualizações já feitas para gente testar do zero?


#38

Bom dia @galactus, você esta correto já geramos uma nova ISO e disponibilizamos ela para download no site do LE, o erro foi corrigido agora e os usuários são criados normalmente na versão escola.
Obrigado pela sua contribuição.


#39

Olá pessoal!

Farei um “primeiras impressões” do LE6 Estável!

Fazendo uma instalação toda padrão pelo assistente, ainda dessa vez não optei pela versão aluno, usei a versão escola, tudo correu bem!

Não detectei nenhum dos erros que afligiam as versões Beta.

Achei ótimo que, ao menos na versão escola, o acesso aos repositórios pelo Synaptic está liberado!

E outra coisa muito boa é que ele não trava mais o apt logo de cara após o boot para verificar atualizações automáticas do sistema, isso era muito irritante nas versões de teste.

Dois pontos para equipe de desenvolvimento!

Logo após o boot ele tá consumindo cerca de 560MB! Se abrir o Firefox e mais duas abas o consumo pula para 1GB, fácil assim! É isso senhora e senhores queridos administradores de máquinas de velhos pregões!
A modernidade bate a sua porta!

Apesar do consumo “Gnômico”, desculpe não pude resistir, o sistema está bem mais esperto do que as versões de testes e principalmente com todas as atualizações do sistema que eram feitas. Mas atenção! É um Gnome Shell! Não é um XFCE ou LXDE! Sendo assim, para o seu ambiente gráfico ele está rápido!

Visualmente está bonito e como já disse antes a interface gráfica customizada do Gnome serve muito bem ao propósito da distribuição!

Agora estão usando o kernel 4.10 como padrão do sistema. Em máquinas mais recentes é uma boa pedida, mas em máquinas mais antigas sei que vai representar uma sobrecarga a mais para o sistema, se o for este o seu caso, uma máquina de pregões 2008/2010, sugiro que use o kernel 4.4 LTS presente nos repositórios do LE6! Isso se você tiver memória suficiente para tocar o LE6!

Farei mais testes a fundo ao longo dos próximos dias, vou postando mais impressões no decorrer disso.

Até mais e parabéns pelo ótimo trabalho da equipe de desenvolvimento!


#40

Bom dia @galactus obrigado pelo seu feedback!
Em relação ao consumo de memória estamos fazendo de tudo para manter uma interface agradável e acessível a toda comunidade mas também levamos em conta o consumo de memória e a capacidade das máquinas disponíveis nas escolas.
A versão do kernel utilizada na ISO que será lançada quinta-feira (04/12/2017) será a mais recente do kernel 4.4 LTS, visando estabilidade para as máquinas dos laboratórios como já dito em um outro tópico.


#41

Bom dia,
falha login

Essa é a falha que apresentava na ISO anterior e na ISO atual também continua do mesmo jeito. somente no usuário aluno, guest, é que consigo entrar! nos outros pede pra mudar a senha e confirmar a nova senha, mas não sai disso!


#42

Bom dia @ricardo_nteceilandia, isso faz parte da política de segurança do Ubuntu, e o que ele esta pedindo é para que o usuário após instalar o sistema altere a senha tanto do professor quanto do admin. Como de padrão a senha é o nome do usuário, assim para acessar a conta do professor pela primeira vez deve seguir os seguintes passos:

  1. Digitar a senha do usuário(professor).
  2. Logo aparecerá a imagem que você enviou, então digite novamente a senha do usuário(professor).
  3. Então o sistema vai pedir que entre com uma nova senha.
  4. E então confirme a mudança digitando a nova senha novamente.

O mesmo ocorre para o usuário admin, o sistema não vai permitir que altere a senha caso mantenha a mesma da antiga apenas alterando entre maiúsculas e minúsculas por exemplo.


Senha do login professor e admin
Problemas com os usuários do LE 6